Download

Importing textures make them VT automatically in 4.25.1

It seems I didn’t have this issue before. Anyone?

Update1:

So I found that right clicking on them you can convert them back to a regular texture but I don’t understand why they get imported straight as VT. Shouldn’t it ask if you want to import as regular or VT?

not sure on the import, but how are you using the texture in the material matters.
a VT cna possibly sample differently then another texture.
linear color, color, Grayscale, etc.

Of you made a texture object parameter and you pass it off to a function, or into the Tex field of a texture sample, you have to match the texture sample type to the correct texture type.

This means that if you have a normal you can’t replace it with a diffuse in the material instance without getting errors (And its a good thing, since otherwise the rendering would be off).

Not sure if thats whay is happening for you, or if it helps any.

As far as the rest. I have VT on and when I import TGA files they work fine without automatically becoming VTs.

Yeah I know about the sampler type. I just didn’t know it was due to that until later I realized the texture had the VT on the corner and I updated the title and info of the post. I’ve updated the initial post.

Weird thing it does that for me when importing any format. I am using 4.25.1. I didn’t have this issue a couple of days ago with 4.25.0 I believe.

Hei, when you enable the Virtual Texturing in the Project Settings there is a tab telling you, will convert each texture map with the same resolution or bigger to VT. Make it bigger than 4k.