Importing Static Mesh and Materials

Hello,

Firstly, this is my first post, so be gentle :wink: To give a background, I’m using an MBP 2012, with 16GB RAM, and Intel HD Graphics 4000 1GB. I know it’s not the best machine for this, but its temporary, at least for me to pick this up. I’ve got Unreal Engine 4.4.3 installed. I created a blank project, and included the starter content.

I imported a .obj with default settings at the FBX Import Options. You can download the .obj from here: Dropbox - Error. It was added into the scene, and I could translate, rotate, and scale it.

I then imported its texture map, but got a warning about not being a power of two. It was a 3000x3000 .jpg, so I resized it to 2048x2048. It imported fine. You can download it here: Dropbox - Error (this is the 3000x3000 .jpg). I right-clicked on the imported .jpg, and clicked Create Material. I then saved.

I dragged the newly created material to the static mesh, and it works great! Static mesh looks great, and the material on it looks great!

Under Play Options, I set it to Standalone Game. I then clicked on Build, then clicked Save. Then, I clicked Play. Some parts of the shoe doesn’t appear right, like there’re patches of black stuff on it. Then, under Play Options, I set it to Mobile Viewer, then clicked Play, the Mobile Viewer came up, but now the static mesh that I imported look really messed up. It looks like shards of glass. The material is no longer correct too.

So here’re my questions:

  1. Are there any optimized .obj that I should import? Maybe my .obj is too big? Or too small?
  2. What is the best size for the materials? Is 2048x2048 the max it can go? Or is that too big? Maybe I should go smaller?
  3. How do I get the static mesh to work perfectly fine in Mobile Viewer?
  4. Also, I notice the chair from the starter content don’t look like high resolution. How do I enable the quality just like on the desktop?
  5. I’ve tried it on a real device, the iPhone 6, and the issue in Question 4 above persists. From the documentation, it says that it should be all great (green) for iPhone 5s, so am assuming iPhone 6 is gonna be better too

Okay, that’s all the questions I have for now. I’ll have more very soon, but sure hope some of you can lend a hand.

Thanks!

  1. just use fbx because there are some limitations with obj :slight_smile:

https://forums.unrealengine.com/show...Update-Preview
New: OBJ Mesh File Format Support
You can now import .obj files for static meshes!
The file format is very simple so keep in mind that it does not support the following features:

  • Vertex color importing.
  • Collision importing.
  • Tangent and binormal importing.
  • Transforms.
  • The model will be rotated if not modeled with Z up because with OBJ importing we have no way of getting the source coordinate system.
  1. it depends on the complexity/size of the mesh and where you will use it Texture size and best format - General Discussion - Unreal Engine Forums
  2. I havent checked your files, but it sounds like a lightmap issue -> do you get any warnings when you rebuild the light?

Edit: I just tested your mesh -> increase the lightmap resolution of your mesh or create a 2nd uv channel with a good lightmap (currently you are using the 1st uv as a lightmap) -> UDK: Lightmapping Basics and 18 Important Principles for Creating and Using Lightmaps for UDK

Hello fighter5347,

Thanks for your reply, and thanks for the tips!

So here’s what I did:

  1. With the .obj, since you’ve suggested to get it converted to FBX, I did a search and found that I should be using the Autodesk FBX Converter. I downloaded the 2012.2 version, since I’ve read that it’s not as buggy as the new ones. I managed to convert the .obj to .fbx, and I repeated my steps above, importing the .fbx into Content Browser, and 2. as suggested by your link, I reduced the size of the .jpg to 1024x1024, and got that imported as well. However, despite all that, I’m still seeing the same issues in Mobile Preview. The mesh is distorted, like a bunch of shards of glass.

  2. I doubled clicked on the mesh, and under Details > Lighting, I checked on Overridden Light, and then instead of 64, I increased it to 200. I clicked Build, Save, and Play (with Standalone Game), and it looks great! But question here is, how much should I increase it to? 200? 400? What is the “magic number”? I shall read more on the link you’ve given.

One again, thanks, fighter5347! With regards to my earlier questions, 4 and 5, maybe someone else can shed some light. Thank you!

  1. stay as low as possible -> with a good lightmap you can use a low value :slight_smile:
  2. could you post a picture