Importing skeletal mesh - missing part of model

This is my first time posting a question - I see that there are similar questions posted previously but I’m not seeing a resolution and I’m hoping someone can help.

I have a model of Mario that I just added an armature to this morning using Blender. I was able to successfully export the .fbx and import it into Unreal without a problem before I created the armature. However, now when I try to import, it only imports part of the model (it omits Mario’s hat, eyes, etc.). I’m fairly certain that this has something to do with the armature, because when I import it as a mesh (not a skeletal mesh), it works just fine. Any ideas on what I’m doing wrong?

Thanks in advance!

…has to do with your skinning most likely. make sure those meshes that are missing are driven by at least one bone…? maybe take screen shots?

That sounds about right. The objects that are left out don’t have any bones associated with them (mustache, eyebrows, etc). Any ideas on how I could fix the problem? Maybe what happened was that I only selected the body when I made the armature a parent of the mesh. Do I have to redo that step?

Thanks for your reply!


OK I’ve been working on this for a few hours and I’m still having issues. I tried making the missing objects (hat, eyebrows, mustache, etc.) children of the geo-body mesh (geo-body is the main part you see in the second pic). I thought this would work, because the gloves are children of geo-body, but nope, it didn’t. When I went into pose mode I would move the head and the facial features would stay put.

Then I tried to make the “head” bone the parent of the missing facial objects. When I did, those objects were inexplicably moved to random coordinates in the scene. I’m sure they’re not random, but my point is I can’t figure out why they don’t just stay where they are.

Any advice I can get on binding these objects to a bone (or another part of the mesh) to make them work properly would be appreciated.

I should also add that when I open the .fbx file with visual studio, I can see all of the elements that don’t show up in the unreal editor. So I know that they’re getting exported, they’re just not getting imported in Unreal - or if they are, I just don’t see them…

Add those meshes to a Bone. You have to if it’s part of a skeletal mesh…

They should be anyway for animation purposes. You could technically attach those meshes to a socket but it would’nt make any sense. just add bones to the face for facial animation