Importing skel mesh in different scale

I have found when you imported skel mesh in different scale your sockets will be big and you won’t be able to scale down bodies in Phys Asset.

100% repro:

  • Buy this asset: http://www.3dmodels-textures.com/Sci-Fi-characters/robot3
  • Import FBX to UE4 with scale 6,
  • Create physics asset from the skeleton,
  • Try to scale down some body. Issue here: can’t scale down,and you will see weird behaviors when running simulation. Some bodies are trying to get to old rot,
  • Issue here: Create new socket in the skeleton and you will see that it have big scale,

Hey intoxicat3,

Unfortunately, I cannot purchase this asset for testing. If you could please reproduce this using a free skeletal asset, and provide me with some images as reference to see the issue you are reporting, I can more effectively assist you.

Thank you,

Andrew Hurley

Andrew - I can buy the asset for you as a gift, really. Full repro steps can be achieved easily with this mesh. I have another mesh that needed to be imported with 20 uniform scale, and I can see really weird things in Phys Asset - I think that they don’t recognise the Scale and trying to move to location with normal scale. This is major issue in my opinion.

Hey intoxicat3,

I appreciate the offer, but we cannot accept gifts from users for various reasons.

I suggest importing the mesh into an external modeling program like 3ds Max, Maya, or Blender and scale it within the program. Then export that scaled mesh into UE4 so you do not have to scale it so much within the editor.

Scaling the your physics asset will cause all types of issues as they rely on their sizes when simulating physics.

Regards,

Andrew Hurley

Thanks Andrew for trying to help me out!

I can’t scale it in external program because animation will be broken then - it need to be scaled by animator because of the weird skin and this will take couple of days.

So why there is an option for Uniform Scale when importing skel mesh if it won’t work with Phys Asset?

People will start to use assets from different stores than Unreal Marketplace and you should have some budget to test some of them. It’s only 15 EUR.

Still - thanks for trying!

You are welcome,

You can scale the Mesh itself, just not the root for the animation.

If you can reproduce this using the default Skeletal Mesh in UE4 and provide me with some simple steps to follow, I will be happy to continue to assist you.

Cheers,

Andrew Hurley

Yes I have simple repro in 4.8 - should be the same in 4.9!

Create Third Person Project

Export SK_Mannequin to FBX

Import it with 20 Uniform Scale

Create physical asset from him - default settings.

Select “Selected Simulation” and select “calf_twist_01_r” body

Simulate - you will see that body is trying to get to location from scale 1. (you could disable collisions for all bodies and this body is traveling to location from scale 1 not scale 20)

Here’s the video of the issue: - YouTube
It’s really annoying I can’t create ragdolls on skel meshes with different scale than 1.

Hi Andrew, any news on this?

Hey intoxicat3,

After some digging I found a bug report has been entered for this issue (UE-15388).

Currently, it has not been addressed by our engineers as this workflow is not suggested. To avoid this weird behavior I would export your Skeletal mesh at the size you would like to have it in game, to avoid re-scaling upon import.

Would you also mind testing this in 4.9 release to confirm the behavior you are reporting?

Thank you,

Andrew Hurley