Download

Importing problems

Hi guys

I just got UE4 and i’m having problems with importing models. I didn’t have this problem with UDK. But essentially what happens is everytime i import a model it just has blotchy black bits all over it.

Here is an image to show you.

This next image isn’t anything to do with it is it?

and if so how do i fix it?

Cheers in advance!

  1. Which 3d program do you use?
  2. The warning on the 2nd picture has nothing to do with your problem
  3. Check your lightmaps and make sure that you have a 2nd uv channel

well the message is telling you your fbx file is a newer version then UE4’s importer, I don’t know if its the cause of your issues though. when importing have you tried the each of the “normals” options, might help(worked on a test model I imported ages ago).

I’m using Maya 2014 and i’ll check now :’)

Nope none of those idea’s seemed to of worked unfortunately. :frowning:

What happens when you assign a material to it?

Then it looks the same but with a material on it basically :frowning:

Hmm, could you probably upload the file (fbx) somewhere so that we can take a look at it? -> I have seen this problem in UDK some months ago, but I can’t remember how I fixed it :rolleyes:

So i gave my friend the obj files and he flipped the normals and it comes out fine in UE4 (he’s using max) and when i do it, it still comes out all black and stuff

  1. Try to export your file with the 2013 and 2014 version of fbx (the 2014 wont work correctly, but probably it will somehow solve the problem)
  2. So you already flipped the normals?
  3. Could you probably post your step by step exporting process?
  4. Import the obj file that you have sent to your friend into maya and without doing anything with the mesh, just export and import it into the UE4

Hey guys

I fixed the problem in the end. Seems like a long way about doing it but basically i downloaded blender, imported the model into blender as a OBJ and then flipped the normals in blender and Exported out as an FBX, problem solved.

Cheers for all the help!

What were your import settings when importing?

Hey,

I had the same problem. Problem fixed by using the 2013 FBX Version.

Cheers