Importing problems

Hello, i had been using 3dsmax and Cinema4d. When i imported my 3d models into UE4, i found a lot of problems like ( degenerate tangents, shadows, exporting settings or import…) basically i put these images to show you a little bit. I really need that help because i can’t make my own enviroments and it’s really stressful. :slight_smile:

Sorry that this isn’t an answer but a question, but how did you import the models in the first place? I’m having trouble with this now.

This is the easier part, you just have to export your 3D model from your program( 3dsMax,Maya…) and the only thing you have to do is click the button “Import” in UE4 and select your FBX file.

Did you check from which side the normals of your models are beeing rendered? If the wall is made out of only one plane of polygons then you should use a material which is rendered from both sides (there is a checkbox for that in the material editor). Also I wouldn’t recommend exporting with C4D. I’ve been using it it the first place and it went horribly wrong so try sticking with 3ds max, maya or blender. And what are your export and import settings? Do you have a seccond UV set for the lightmaps and if not did you check the checkbox for auto generating these when importing and did you set a LOD group?

Did you check from which side the normals of your models are beeing rendered? : Sorry but i don’t understand at all what do you mean.
Secondly, there’s not material in that model put it inside 3dsMax, but it’s really strange because I thought i could have my 3d model done without any problem simply exporting from 3dsMax and importing into UE4. Also I found a lot of problems between Cinema4D and Unreal Engine. Now I’m starting to use 3ds and learn a lot of things about modelling, textures… THE MAIN PROBLEMS are:

When I simply extrude any object or model on 3dsMax. I had problems with tangents. As these:

About the 2nd UV, it is really annoying for me XD. I was looking for videos or something like to find how to do it but i didn’t get it. ( So if you can tell how , it would be fine.)

Some of bad things that UE4 said me when i built the light are: overlapping UV 40 %, smoothing groups, degenerate tangent

Also, here are my exporting and importing settings:

Simply i want to know how to get in my models on ue4 without problems :frowning: I want progress with engine but i can’t. And sorry for my english and the big text ;). TY!

First of all the lightmap UV thing: UDK: Lightmap Basics - Introduction to Lightmapping with UDK Part 1/4 [Tutorial #18] - YouTube

It’s a 4 part series for UDK with maya but it’s working for UE4 as well. You can also let UE4 generate the lightmap UVs:

I wouldn’t/shouldn’t recomend using auto generating lightmap UVs because it’s not precise enough but you can try it.

Here are my export settings. I’m using maya but it shouldn’t be that much of a difference:


The normals define since which angle you models edges are beeing smoothed out and from which side a polygon is beeing rendered:

You can let the engine render a polygon from both sides by making a material two-sided:


I hope I didn’t forgot anything. Just watch a few tutorials and play arround with some settings on your own (that’s how I did it :wink: ).

These stuff that you gave me was quite good really appreciate it! I got succeed in the problem of the example of the walls but there’s again a problem with the shadows that it’s really strange. I put all the options and settings that you told me but i couldn’t find the “reverse” option on 3dsMax. Also I tried to make a second UV for the model, but i don’t know exactly if i did it right or not… Here are different images to help you a little bit.

If you want to see if all UV maps got imported just go to the content browser, double click on the model you’ve imported and then there should be some text saying how many UV sets the models has. Just look arround and click some buttons. I can’t make any pics right now cause I’m on my laptop so sorry for that but I’m sure you’ll find something useful. About the shadows: You need to increase the resolution of the lightmaps. The bigger the model the higher the resolution should be but try to keep the resolution as low as possible. You can find the setting under the Details panel either in the window you’ve opened before by double clicking the model in the content browser, or you can click on a model in the scene/viewport and with it selected look under the Details panel. By doing that you can change the resolutions individually for every model in the level. Also, I would create the walls of a building by using two sets of polygons (so the walls have some actual width/ are 3 dimensional) cause otherwise it just looks weird. That’s of course for buildings the player can walk into. And try to keep the amount of triangles as low as possible. Oh and you can take a look at that: Help with "Flip Normals" - Autodesk Community
or that: The Page You Were Looking for Was Not Found