Download

Importing Problem

Hello, when i import my .obj or .fbx file to unreal(from content browser), it starts from loading then suddenly stop loading and as i can tell it just crashed, who knows what problem that could cause? The engine? Bad file? Other mistakes? I have i7 3,4ghz, 8 ram, 750ti geforce computer if you think thats the problem. I just sculpted simple creature with sculptris, thought i could animate with unreal. Or unreal doesnt support not quite finished models? Im still new, i dont get it :slight_smile:

-it could be that your file is corrupt -> when you upload it somewhere we could check it
-could you post your crash log -> project-saved-logs
-tri count of your mesh?
-rename it to e.g test and then try it again
-are you abel to import other meshes?

In the UE4 you can just create basic movements animations -> with matinee. Everything else has to be done in a 3d program :slight_smile:

While loading it crashed. Had to use “start Task manager” to shut off the program. The others of mine after long load managed to pull it out, but i got another newbies problem, my mesh imported very small and all white(no colors).

Untitled.png

Ok, so i must be doing wrong with my meshes. ohh, i need to learn more of that… :slight_smile:

I can attest to UE editor crashing from importing, not really hard to do.

Are you importing from Blender? If so, make sure you have smoothing groups selected when exporting the model, either face or vertex smoothing will work, if you have ‘none’ selected it’ll crash. This might be expected in the editor, no matter what modeling software you use. (just from noticing your first line the warning about smoothing groups)

also, I see the warning about the size of your mesh being too small, UE uses a scale of 1uu = 1cm (1 unit = 1 centimeter). youtube is full of model importing videos that might help. (Blender models have to be scaled up before exporting, using normal scale in Blender of 1 unit = 1 meter, the model has to be scaled up by about 8 & the scaling ‘Applied’.)(note: skeletons don’t export well out of Blender)

good luck. :wink:

When you use 3ds max or maya, you will have to enable “smoothing” in the export settings :slight_smile:

It hasn’t crashed once for me when I haven’t used smoothing in blender.

What I have had is the editor hang for a minute or two when importing, but never crash. Has the editor popped up explicitly saying that its crashed? Or has it just frozen momentarily?

Just Frozen, as i said, i had to use “Task manager” to force shut down. The others were frozen also, but in some time it finished.

@ Justas, we really need to know which 3d programm your using, this will help us work out whats wrong , also is it a static mesh or a skeletal mesh

  1. i’m guessing your using blender, so scale your mesh by 100 then reset the scale then export again