Importing Mixamo Animations into Unreal does not work - urgently need help

Simply trying to import animations from Mixamo to Unreal. Importing a single animation gives this error.
“mesh contains root bone as root but animation doesn’t contain the root track. import failed”
A simple google search shows other people also are experiencing the same issue and link to this tutorial, however, the link goes nowhere.…ons/index.html
Many sources claim this is the solution, as late as 2019. I don’t think the solution has been archived anywhere.
So my question is, how is it possible to fix this issue?
Any help is appreciated, I will keep attempting to find solutions in the meantime and update the thread if I come upon anything useful;

I think I found a workaround! I uploaded the mesh of the UE4 Mannequin onto mixamo. Downloaded with the skin included. Imported it into Unreal and it worked! Was also able to successfully retarget a characeter model to the mannequin with the animations.

1 Like

Update: Any animations I make in mixamo have floaty feet. I’m not sure how else to describe it. It’s more noticeable in certain animations. Here is an example.
What the animation is supposed to look like Screen capture - 6ba15e7e6c15b2e211e883929b0af361 - Gyazo
What the animation looks like in Unreal Screen capture - 8bd98d6f68b6f87caaa149458cc300bf - Gyazo

Here is another example.
What it’s supposed to look like Screen capture - ae980e67a7d8297248ee44f2bb87166a - Gyazo
What it looks like in Unreal Screen capture - 142cecd548a30b4610719b258c229f5f - Gyazo

It’s just especially frustrating because it wasn’t too long ago that mixamo disabled their ‘export for unreal’ option.

I may have found a solution, bless whoever wrote this Retargeting Mixamo In-Place Animation To Epic Skeleton - Community Content, Tools and Tutorials - Unreal Engine Forums

and it doesn’t exist anymore…cheers to 3 years


This is for anyone like me who YEARS down the line might need help I found a solution…

My problem: I couldn’t get my mixamo animations into UE5 because of a root error where my characters skeleton in UE5 only had a “root” bone and so it wouldn’t let me import the animation from mixamo

How I fixed this: I got my character and auto rigged them with ActorCore AccuRIG (It’s free) once I did that I exported it with the material on the character plus the targeting application was set to “blender” and the texture was original size with the “emed textures” option unchecked now for this it will mess up your character if you have multiple parts to it for example my character is Reyna from Apex Legends the model I got for her has 3 different parts so her body is one part her hair is another part and her chest is the third part so they are all individual parts anyways so when I imported into unreal THIS PART IS IMPORTANT PLEASE READ THIS
I imported into Unreal Engine With Skeletal Mesh and Import Mesh both checked I had none selected for my skeleton make sure you do that so it creates the skeleton for you… with Material Import Method on “Create new materials” and I hit import NOT “import all” I then needed the materials to apply from the model to apply to the hair and chest because it only gave me the main material for the body but the hair and chest are another 2 materials so 3 all together but when i applied it was all good!

Sorry this is so long I wanted to make sure everyone didn’t struggle I hope this helps someone down the line

idk if you’ve tried the Terribilis mixamo converter, but it’s a very easy way to import animations! Mixamo Converter

It took me a minute to figure out, but basically just download the converter, open it, click “enter the conversion process”, select the proper mannequin, then upload it to mixamo, grab your animation, and select “open the folder with original animations”, drag and drop it in there, then it’ll convert it and you can start using it instantly