Download

Importing Landscape Heightmap Generated in Blender - inaccurate results

Blender has a really nice built-in plugin that can create really nice landscapes procedurally. For this reason I am making a “draft” of my landscape in Blender and touching it up in Unreal Engine. I have been able to bake a heightmap in Blender, but importing that as a landscape doesn’t work as expected in Unreal Engine. Here is a comparison of what I’m getting in Unreal Engine vs. a mesh in Blender that is made using the same heightmap.

&stc=1

&stc=1

The mountain parts of the landscape are fine - proper height, proper proportions, etc. However, look at the “valleys” - in Blender, these are fairly flat (which is how they also are in the original mesh that I baked from), whereas in Unreal they are very steep and deep. This is evident in the first image how the Blender mesh is more shallow overall, especially from the origin-down, but the mountainous regions - i.e. origin-up - are nearly identical in both Blender and Unreal.

The Blender mesh has no special parameters or extra stuff added so that these valleys should be flat. I’m wondering what is causing this in Unreal, and what my solutions are, more specifically if there are any other than manually sculpting shallower valleys in Unreal or editing the image in Photoshop. Perhaps it is with my import settings, seen below?

QuNxVXU.png&stc=1

Any ideas?

[Also, if anyone knows how I can get rid of the edges of the landscape being clamped and stretch out as they are - the image is a proper 2048x2048…]

Rescale the heightmap to 2296x2296. This may helpto fix the border offset. Regarding the different appearance of hills and valley. Looks like the color curve is different.
Maybe and SRGB or Gamma problem. you could try to apply an inverse 2.2 Gamma curve to the heightmap in some image editing software.

Huzzah! The Gamma curve did it! Also, someone on AnswerHub pointed out the Landscape Technical Guide page (https://docs.unrealengine.com/latest/INT/Engine/Landscape/TechnicalGuide/#recommendedlandscapesizes), which suggests 2017x2017.

Here is how it is done in Photoshop, for those curious:

cUkylFO.png&stc=1

(.45454545… = 2.2^(-1))

The problem with the offset will start once you try to apply mask textures with landscape coordinates wich will not fit when you have this offset. The only way I found to get rid of the offset is by making the heightmap the exact size of the overall resolution. I wonder why the overall resolution is never a value by the power of two. Btw. If you wanna make Landscapes you may want to take a look at WorldMachine.
Great piece of Software. Best Errosion Filters I have seen.