Download

Importing issue (Blender)

Hello,

I’m trying to import a static mesh and the related skeleton mesh with some animations from Blender 2.78 into UE4 4.12.5.

It works just fine, but for some reason UE4 doesn’t adopt the smoothing groups I set in Blender. But if I import a static mesh on its own, it does. Even though I get a warning information here, that no smoothing group information was found, UE4 displays the static mesh correctly. Just if the fbx-file also contains the skeleton mesh it just won’t work.

In Blender I just turn on smooth shading and use an edge split modifier without applying it. In the export settings “apply modifiers” is checked though.

Also the reimport function doesn’t seem to work at all for me. UE4 says the static mesh was successfully reimported, but it’s still the old one.

Thanks in advance and best regards!

Instead of using Edge Split, you can use the Normals Auto Smooth and set the angle to whatever (unless you already set the sharpened edges, then you put the angle to 180), this is normally how I do my meshes in Blender, I don’t use the Edge Split modifier:

1090a2fde6104d6592495d08cf62c770.png

Hopefully that can help with the smoothing. :slight_smile:

Thanks a lot for you answer, but unfortunately it didn’t work. When I just import it as a normal static mesh, UE4 uses the smoothing I set in Blender. But whenever I choose “import as skeletal mesh”, it doesn’t. Now I tried to import it with “flat smoothing” and UE4 still shows me the smoothed egdes. It’s really weird…

Edit: Triangulating the faces inside Blender didn’t help either. I also created a new, simplier mesh and tried to export it with both exporter versions (FBX 7.4 binary and FBX 6.1 ASCII). Whatever I do, UE4 smoothes all edges and I always get this “The bone size is too small to create physics asset” warning information.

CotySA just came across your post. We are having a similar issue with our skeletal mesh import and smoothing groups or normals in UE4. It’s been extremely annoying. Did you happen to find any solutions to this?

Meanwhile here’s our thread and Answerhub submissions, no solutions yet from anybody unfortunately so far…

https://forums.unrealengine.com/showthread.php?132159-FBX-and-normals-Import-going-very-wrong!

https://answers.unrealengine.com/questions/539768/help-with-smoothing-and-fbx-import-issues.html?sort=oldest

Unfortunately I still have no explaination for that. I tried it again a few days later and it suddenly worked. I thought “Okay, problem solved”, but the next time I wanted to import something to UE4 the same problem occured again. :frowning:

I also had the problem of getting the warning that no smoothing groups were found, even though it was smoothed in engine. I recently fixed this with an option when exporting.

Where it has a box for smoothing, the default says “normal only,” but seems to fix the problem when I switch that to “Face.”

This option seems to only be present for the FBX 6.1 ASCII, and not for the FBX 7.4 binary, at least for 2.77. I think it worked for both for 2.75, but am unsure. The correct faces are smooth, and I get no warnings.

For me every edge gets smoothed by UE4, whether I want it to be smoothed or not. I already tried everything I can think of. FBX 7.4 binary and FBX 6.1 ASCII. Choosing Face, Edge or Normal for the Smoothing option in the exporter (I don´t get a warning that no smoothing group information was found in UE4 if I choose Face or Edge though). Using the smooth shading in the tool bar, the smooth shading in the object data or an edge split modifier.

But this problem only occurs if I want to import a Skeletal Mesh with a Skeleton. I never had it when I imported Static Meshes.

I still can´t find a solution for this. :frowning:

Edit: Marking the desired edges as sharp (Ctrl+E → Mark Sharp) combined with the Object Data Auto Smoothing and choosing “Edge” in the export smoothing options gave me now some hard edges on my Skeletal Mesh! :cool: Well, I still have no clue why UE4 auto smoothes my Skeletal Meshes and that solution seems kinda inconvenient, but at least it works.