Download

Importing from C4D...

Can’t figure out why I am struggling so much with this, but I have just one mesh in c4d and it has 3 polygon selection tags assigned to it. But when I import it into ue4 I cant get it to assign the 3 material slots. It just brings in 1. I tried so many things I don’t understand why its not working. Anyone have a tutorial to follow that I somehow haven’t looked up already. I am trying to make the 3 materials in ue4 and use the tags I created in c4d to assign them 3 materials. Pretty basic so I must be missing a checkbox or something…

I got it work properly if I go from C4d, to modo, to ue4… So not quite sure why it doesn’t work from c4d to ue4 straight.

Using R19 if that makes a difference.

Thanks!

You have to make sure that the selections have different names.

A few possible reasons.

export/import settings:
Make sure to set the material export options in the fbx export dialog
Also check out different fbx versions for compatibility.
From my experience fbx 6.1 works best. In R17 it is even able to import textures and tiling into UE4.
Maybe in R19 it’s different, so try it yourself.

mesh setup:
I’ve learnt that the order of tags can make a difference in certain situation, too.
e.g. if you use two UV channels aka two UVW Tags with a unique name, your materials have to be on the left side.
Otherwise you’ll get an error message on Import that no materials are assigned and a default Material is used.

Also i think that on a Mesh with multiple Materials every Material has to have a Selection.
So no Materials without Selection or Polygons without Material.
(not entirely sure about the first one, would have to test this)