Download

Importing FBX House collision problems

I get a player start “bad size” error.
Well this has nothing to do with the size, it has to do with the default collision setting when importing an FBX file

Let me explain…
I click on File->Import Into Level

On the “Scene” tab
For Hierarchy Type…I pick “Create Level Actors”
I am not dead set on this choice, but it is only option, whereby I can edit collision settings correctly.
The only bad thing, is that instead of one item listed is the world outliner (ie House)
I have the entire contents of the House listed…

On the “Static Meshes” tab
I UNcheck “Generate Missing Collision”…well, this means I have to set it up manually.
If I DON"T uncheck this option, the imported House FBX file will have the collisions set up incorrectly…which will generate the “bad size” error.

Well I wouldn’t mind setting up the collision properly, but there seems to be no way to do this “in bulk” fashion.
I have to select the mesh and the right click to edit the mesh.
On the right under “Additional Data”
Below…I have to set the “Collision Complexity” to “Use Complex Collision as Simple”
For all the walls and or floors in my House FBX imported model.
But there is no way for me to select multiple walls and floors so that I can do this in one bulk operation…I have to do it on a wall mesh by wall mesh basis…which gets tedious really fast.

I tried to use DataSmith, but this only works in 4.23…
If I try to enable the plugin in 4.27, it will not work with “standard” fair FBX files.

It depends on what you’re importing, the collision generation might not give you a good result, you can try to tweak it on each mesh or you can model your own collision mesh. For a house it could have problems if too many parts are in a single mesh, it might fill in spaces that you don’t want filled in.