Download

Importing FBX animation overwrite previous

I imported skeletal mesh, than imported some animation frame range like 0-20, it is saved with a default name.
It is a way to change the animation name ?
Caus every time i imported another frames range animation it just overwrites the previous one ('im using Blender 2.7).

Some work around that works for now is to create one subfolder for each animation, this way they don’t overwrite each other.
6921b84791b1cf5deab16feaef0329274713744e.jpeg

EDIT :
Some problems :

  1. Another problem is my model character when not animated is horizontal facing the floor, only plaing animation make it stays vertical like in BLender. It is some bone root convention or some reset scale or position on armature or character to do ? (i use armature only not regify)
  2. Importing some frame like like 80-120, it just imports 33 frames. Same problem for other animations they are cut down it imports less frames than the total lenght specified.
  3. i have scaled and moved above floor the character in Blender, after importing it , when i view it if i clikc some animation the model is scaled up and moved up. Does this means we can’t scale and move a character before export ?

Just do a right click onto the anim -> rename or just rename them in your 3d program (in the action editor you can just type in another name) :slight_smile:

Thanks, i edited my post with some other issues.
EDIT :
Making some Tpose in frame 0 , resolved the sacling and offset problem of the model, now playing animations it stays at it’s place and keep it’s scaling.

Other problem the physics are totally impossible to use, how to do ? re create physics manually ?

http://s9.postimg.org/kab8plbdb/ue42.jpg

Note : Blender 2.71 proposes a binary FBX export, but that don’t work, you must keep Ascii export for UE4

I always just rescale those volumes

Yes it’s better rescaling.
The problem is that only 7 volumes where created for bones, and my character have 15 bones. So how can we do to add missing volumes ?

I looked at the steps from FBX import :
https://wiki.unrealengine.com/Creating_a_Skeletal_Mesh_in_Blender#Creating_a_New_Scene
So the character in the scene could it be static or animated is ok now , with same orientation and scaling, this works when i follow these three steps import : 1) import static 2) import riggged character 3) animations import

There is still the frames number issue and physic volumes number issue.

I had the character facing down problem too, I fixed it by unparenting the mesh from the armature, this will also fix having to use T0 as ref pose. Also, you should always export with scale set to 1 in the FBX exporter. You can scale up your objects in blender, ctrl+a and apply scale and your armatures will import with correct scaling. I like to use metres to get the right size when making objects and by default unreal uses 1 unit = 1cm, so in blenders scene tab I set the units to metric, and the scale to 0.01, and this makes 1cm in blender = 1 cm in unreal.

For the facing problem in Blender you don’t need to unparent model and armature, when exporting to FBX you can choose the option "Forward " , i just put “Y Forward” and it works. About scaling i didn’t had to deal with them as importing the mesh first than importing the skeleton having T pose at frame 0 , resolved the scaling issue.
About physic volumes , as i use only character capsule collision only and no ragdoll , i don’t need them for now.
What is blocking is frames range not respected when importing anims, and there is no tool in the editor to make animations with frames from the track imported.