Importing datatable with array struct member

I want to import data from a csv into a datatable.

The struct I created for the table contains a variable (FollowUpId) of type string-array. How do I format the column in csv in such a way that the importer of the engine recognizes this column as an array and will import the array?

I tried comma-separating the items within the column FollowUpId but that doesn’t do much. I get an error message:
Unsupported Property type for struct member ‘FollowUpId_22_BDA804434825D471523C599DC8970348’.

The other columns are then imported fine. The ‘unsupported’ part of the error message makes me suspect what I want is not possible but to be sure I post it here.


I am curious about this too. Tried many combinations without success.

Arrays are not well supported at the moment; you will have to wait until 4.8 (which is currently in release preview); they added exporting of Datatables (both with and without arrays), Importing with arrays and you can also export your tables as JSON.

p.s. if this was helpful it would be super cool if you accept it as the answer.

Is there a page somewhere that describes the new workflow?

to import a datatable in 4.8 with arrays you simply add parentheses around the array. so using the provided Datatable example ( from this page ) if you want to import integers you might put something like this “(1,2,16,128)” sans quotes.

Sounds like a valid answer for this post.

thanks! I implemented a work around by now with a string-splitter function but as soon as 4.8 is there, I’ll replace it for some proper code

Hi, we’ve just given this a try in 4.8 and have run into a problem:

We’ve got a struct containing two ints (min/max) and an array of another struct (extra). For testing this, ‘extra’ simply contains two ints (A/B).

The image shows the data we tried to import. ‘TestRow1’ works perfectly. ‘TestRow2’ doesn’t work at all and will generate errors on import (i.e. you need to use the full, internal variable name for it to work).