Download

Importing character with controllers from blender

I have this little problem where whenever I try to import my blender character to unreal engine, it gives me the “multiple roots” error. And its quite obvious that my character rig has a few controllers that are actually bones and that can only be possessed in pose mode only.
I don’t want to start over with creating the character controls again. How do I import my character to unreal without issues?

If there’s some kind of constraint that’s controlling the movement of the bones then that animation needs to be baked to keyframes.

no, its no animation, just a character for the main skeleton thing

I’m not sure what you mean, if you have special character controls in Blender it’s not going to export to UE4, the only thing that you can export with a skeleton rig is bones with animation, any special rigging doesn’t convert over, even IK doesn’t convert over.

First I want to export the character itself into unreal so that I could get the main skeleton for the animations. But the controllers are taken into consideration as root bones, which I don’t want that to happen.
With cinema 4d I was able to export the character into unreal with no problem, and it even had fully working controllers.(which are actually nulls/splines and not bones with custom shapes)
Can I like make the controllers in blender get completely removed in the fbx file? so that I could avoid getting a multiple root bone error

You can uncheck “deform bones” on those controller bones and when exporting check “only deform bones”, this way it will export only your normal skeleton

I tried that and it happened the same thing
the controllers are bones in custom shape
But without parents, so they act like a root
Edit: Do bones have like a deform check box in the Bone tab? Do I have to uncheck that in order for that to not be considered as part of the mesh?

I use also custom shapes…
Have you tried to uncheck “add leaf bones” in the blender export settings?

That only adds a new bone as a child to every bone.
The solution was to uncheck the “Deform” check box in the bone tab. Now I got the character into unreal with no problem.

Thank you anyways :smiley:

Topic solved

That’s what I said :slight_smile:

ah sorry, I thought you were talking about the option from the export menu XD

No problem, I realize I should have been more precise