Download

Importing as skeletal mesh effects model differently?

I’ve got this issue where if I import things as a static mesh and apply the materials, it looks perfectly as I want it to, and as I made it in Blender and 3dCoat. The issue is that I need some things to be skeletal meshes obviously, you can’t make a game without them. When I import the exact same model as a skeletal mesh, the edges get smoothed out and it responds differently to the exact same material blueprint. Here’s some examples.

Originally I thought it was something to do with normal maps, but it apparently isn’t, I discovered through messing with it. As you can possibly tell, it looks the same on curved areas, but the edges are dark and the faces between them look “buttery”. Am I skipping something somewhere that effects this? I really need this figured out.

Still haven’t figured this out. I tried exporting the model with sharp edges marked in Blender but that didn’t change anything. Not to mention that doesn’t help me on parts I want to appear smooth, like the top of the hilt.

Okay I figured it out. When exporting the low resolution mesh from Blender as an FBX, you have the option of “normals, faces, edges” for exporting smoothing info. I swapped it from the default “normals only” to “faces” and that fixed the issue within UE4. I don’t know why static meshes don’t need this but skeletals do, but a message in the log complaining about having no smoothing groups tipped me off to the fix.
I had made the smoothing groups, it just wasn’t able to use them.