Download

Importing animation from Maya to Unreal 4.8.3

Hello Forum, I am trying to transfer this animated skeleton mesh from Maya to Unreal 4:

But this model imported into Unreal becomes just a head:
22fa7a53c665588a33f5cddc2368615b706bf708.jpeg 811f35e759dcc4c128f3a5b949f8b29b7091a250.jpeg
Apparently all the nodes are squashed into the main branch, and all the parts of the mesh attached to those nodes as well.
The FBX file also throws some warnings when imported (the constraint part shouldn’t be the major problem, because the same problem happened regardless of the existence):
e.jpg
Maya throws a couple of errors exporting the model as well:
450b9629cc9ea12a8c5b27851c0dd2af14350eef.jpeg
What is expected to be happening here? How would you solve this problem?
Here is the model’s .ma and .fbx files: https://dl.dropboxusercontent.com/u/101732939/toki.zip

Thank you!

Have you tried switching FBX from 2014 to 2013? Make sure you have smoothing groups, animation, and triangulate options on in the FBX exporter.

Thank you CryBaby a lot for your reply.
I tested out FBX 2013, Smoothing Groups and Triangulate options, but I’m afraid to say I got the same problem.

After some different trials, I’m very certain that the “Skin Definition” error is the major problem.
I researched about this error but could not find the exact solution to my case.
I rigged and animated newly, deleted non-deformer history, and none of them worked.

Worked for me when exporting from Maya even though it gave an extra error

54 attributes had complex animation. Complex animation was exported as baked curves. (3294 evaluations done)

Anyways, here’s the copy that worked for me:
Burd.fbx

It seems that the animation wasn’t baked is my guess. When you export it next time try baking the animation from the Key menu.
26a1384b44c692ae4ee385ebe07359a7a9272d2d.png

Thank you dotdog20, I have no idea how it worked in your workstation but I appreciate your copy of the working version.
I tried baking animation but it ended up in the same result. I’m very confused at the moment.

I will try Maya 2016 and see if the Maya version matters.

I am using Maya 2014 and I have the same results as dotdog20. Maybe because you are using the evaluation of Maya?
961207bc651c534fae64bb0fa1c51a051804bcc2.jpeg

So, I imported into UE 4.8.3 and I got this error: 58c8c35a9caf350456ac10ec7897a688541345f9.jpeg

I re-imported, this time I used the “Use TOAs Ref Pose” option under FBX Import Options and got no errors!
27d0c973d7cf6ccf4e26152a73b7f8e034d04825.jpeg

Here is my fbx file…

Thank you CryBaby for your help :slight_smile: