Download

Importing 3dsmax CAT rig combines CAT bones to mesh. Please help

Hi.

When i import my character that has a CAT rig. The bones show up as part of the mesh.
99cda20efcb3517fe0c00c679f00c63ffbb9aadf.jpeg

AS you can see in the picture the square parts are the CAT rig that has been combined.
How can i not combine it. For some reason it sees the bone objects as meshes.

Ok. So right after i posted this i found the issue.
Under FBX export options go to Animation - Characters.

Tick the Box saying CAT Characters as HIK.
This removed the CAT bones being detected as Mesh objects.

Hope this helps someone else.

Wait really that check box works, Crocopede ? Every time i tried to do that i got weird or extra bones and sometimes weird skinning.

I’ve been exporting my skeletal meshes and animations as collada files, reopening them in another instance of max then exporting the imported collada as the normal FBX ue4 exporter options

You might also put a transparent material on the bone objects.

I ticked that box and while it did fix the visibility of some of the bones, many remained visible still. Am I missing something else?

I think you can just export the mesh without the bones and it’ll work.

I thought I had to export the mesh and rig together? Will it no cause problems with animations to not have rig in same fbx file? Sorry if these are simple questions, I am very new to Unreal Engine

Edit: I imported just the mesh and it seems to retain rig data but my root bone is still visible0456c4552d00cc5673f5c23cb61e0410e6188543.jpeg

You can try it and test, but I’m fairly certain that you can export just the mesh and the rig/animations will still work correctly. Might not fix the problem, if maybe it automatically exports the bones as well even if they’re not selected.

Just exporting the mesh selected works, thank you so much. The bones don’t show as meshes in unreal but the root bone itself still does as you can see in the pic i uploaded. Is there something specific i must do with rootbone?

If anyone runs into this issue, one thing to check (This is what did it for me) is this setting here… make sure its unchecked.

Annotation-20200407-000852.png