Imported FBX Rotated 90 degrees

I’m importing an FBX file and for some reason it’s rotated 90 degrees on the X axis. I’m just wondering how I can rotate it so it’s perfectly on the X axis. I don’t mean the rotation tool - I mean I want the actual mesh file to be rotated. Can I do that in UE4 or do I need to open up blender or something to rotate it? I hope this isn’t the case because I have hundreds of FBX files and they all seem to be rotated 90 degrees…

When I open up the mesh, there’s no rotation. I tried messing with the Import Translation options, but they don’t seem to do anything. Any ideas?

Hi jtxp,

it could be that you need to rotate your meshes in Blender before exporting them. According to [this video][1], Blender defines forward on the -Y axis and Unreal uses the +X axis. Rotate your meshes around the Z axis by 90 degree and apply the rotation.

I guess you could also change the export settings here:

33596-blender_export_forward.jpg

although nothing is mentioned in [this wiki entry][3].

I figured it out. When I import the actual mesh, I need to change the rotation option. Thanks for your suggestion though :slight_smile:

I know this is a late reply and already solved, but since I use Rhino for modeling I will add that this is also an issue using Rhino and exporting .fbx . Once you import the fbx to Unreal, on the import options you will have to rotate the X-axis -90. Again this is for meshes brought in from Rhino.