Download

Imported Blender object creates glitchy shadows

Hey,

I’m a beginner in UE5 but I recently followed a Blender to Unreal Engine 5 tutorial. The Animation of the Windmill is created in Blender.
On a freshly created “First Person” Scene in UE5, no settings changed, shadows look like this in UE5:


Edit: When I give the Object a constant but slight rotation from the unreal blueprints via event tick delta seconds the shadows update just fine:

I’m assuming theres a setting that controls how often the shadows get updated?

In the UE5 Asset Editor the shadows look fine, like this:

In UE4 they are also fine (same import settings on the asset):

It’s probably something super simple but I’m totally stuck.
What am I doing wrong in UE5?

Looks like a bug with virtual shadow maps, since it seems to update occasionally my guess is it has something to do with the caching.

Maybe try disabling VSM caching?
r.Shadow.Virtual.Cache 0

1 Like

You’re a genius! Turning off the caching fixed it for now.
The command you mentioned lead me to the following page:
Virtual Shadow Maps | Unreal Engine Documentation
There seem to be some known issues with caching but I’m nowhere close the “max pages” and its not a nanite asset. According to the page disabling the caching only should be used for debugging purposes. Is there a way to enable a higher frequency of shadowmap updates for this object or should I wait for the next version of the EA and see if it will be fixed?

Thanks for your help

I’m not sure that’s possible. Personally if this were my project, I wouldn’t make these skeletal meshes at all. I’d split them up into two parts and rotate the blades with a rotation component or by doing it the way you’re doing above, updating the rotation on tick, or by animating it in the material using WPO (cheapest option, probably)

Skeletal meshes can’t generate distance fields, and WPO can’t move distance fields. So using multiple static meshes will produce the best quality and doing animation like this on tick isn’t unreasonable.

If you’re really attached to using a skelmesh for this though I would just wait it out. That’s my general response to most UE5 issues. Epic has a lot of issues to fix and I don’t think it’s worth it trying to find work-arounds just yet. I’m sure there’s plenty of other things you could work on in the meantime.

That’s just me though, others seem to already be trying to do production work with UE5 so it’s your call.

1 Like