Download

Imported Animations Have Wrong Number of Frames

I’m attempting to import some prototyping animations from Maya. The .FBX file is about 1000 frames long, and contains a pile of different animations. I’ve got all my timestamps worked out, but when I import from the correct times I get an animation of the wrong length. The play back of these animations is also insanely fast - 100 frames plays in less than a second! When I import the whole file, I get this:

So the file should be about 1000 frames in total, but instead it’s 30,000, which plays in 5 seconds! Even more, this 30,000 long import only actually contains about the first 150 frames from my animation.

Is there some setting I’ve toggled which is totally wrecking all my animation imports?

make sure your maya animation playback speed is set to “30 fps”

5ee6718583e6335d27a0e4e763793a34964ae816.png

and when exporting, only export the range of frames your animation is on

In import options, under Animation enable Use Default Sample Rate. This worked for me.

You’re a life saver dude <3 this issue was driving me insane