Imported animations come up empty

As title says.

I imported a skeletal mesh from blender, everything fine. The main root bone is called just “root”.

Then i go to import an animation, i select the previous imported skeleton, and the animation come up empty.

I dont have a clue whats going on. I dont know if im doing something wrong in Blender when exporting or doing something wrong on UE when importing.

I already tried this method with the same result.

I noticed that in the output log i get tons of bone transform errors i also dont know why.

Thanks in advance

Blender to Unreal can sometimes be a nightmare. I’ve made tutorials about it but I handle everything on a case by case basis as I sometimes still get the strangest errors.If you’re willing to share the file I can have a look for you and maybe provide a solution.

Know this sounds like a no-brainer, but check and make sure your entire hierarchy is parented to your root bone (i.e. not having multiple roots). I was having same issue, but unlike most times UE wasn’t spitting errors out at me for some reason. Hope this helps.