Download

Import —> Triangles?

I am trying to import an .obj or .fbx file without triangles.
For some reason, it’s not possible.

The mesh has no visible triangles in 3dsmax. But after importing to Unreal- everything has triangles.

What am I doing wrong?

Why would you even want to import a mesh with no triangles?

I think they mean they’re trying to import a mesh made of quads or something like that.

Oh, right.

Anyway: All rendering engines render triangles, quads are subdivided into triangles at some point.

Even

That is exactly true. 3dsmax hides the triangles so it is easier to model but the triangles are always present even in 3dsmax since a GPU can only draw triangles. I forget where the checkbox is in 3dsmax but there should be an option to reveal the hidden edges. UE4 shows the actual mesh which is why you see everything triangulated.

Thank you… ok… I do understand… soo… what can I do, if I need a geometry with a larger scale (lake, river, etc.) that I want to assign a water shader?
But the export of the geometry contains all the triangulation?

In this example, I want to assign a water shader. But you are going to see the triangles… which looks really bad.
Sooo… what you think I would need to do in order to fix that?

That is either a UV or Normals problem, the mesh looks okay.

Yes looks like a UV Problem. The tilling seems a bit strange. So you could either change the UV or change the material so it’s more seamless.