Import SolidWorks ASM File

Hi I try to import an ASM file from SolidWorks 2017 with datasmith into the product Viewer template but the file is empty after the importation. No geometries, no materials.

Any clues for this ?


Hi! is solidworks installed on your machine? It might be needed for conversion. Have you tried with a .stp file? that SHOULD work!

If its not secret you can send me the files on dropbox!


I have the same problem, however if I make a basic test assembly with multiple parts it seems to work. I didn’t find the exact cause and there is no log after import.

Datasmith may be in beta but it doesn’t really work all that well yet. I really hope they fix this. I have attached my bug report and I hope all of you with issues do the same. This way the issue seems more important. I know the datasmith would be the greatest thing in the world to me if it worked like it was supposed to. Also, it will not work fully, but the issue you seem to be having is that your assembly file is not in the same directory as your parts. This plugin doesn’t work with server assemblies.