Download

Import Skeletal Mesh?

Hey All,

I’m having troubles getting a skeletal mesh to import into UE4. Everytime I import in UE4 it says “asset doesn’t correspond to selected type”. I’ve tried to backtrack to figure out what the problem is and even done something as simple as trying to take the stock third person skeletal mesh, export it to fbx, open in maya, export from maya, and reimport to UE4 and even that gives the same error. I must be missing a step somewhere even though I’ve followed the FBX Skeletal Mesh Pipeline.

Thoughts? I’m using Maya 2014.

Thanks.

**Error Message:
Error Import failed.
Error Error, Could not import HeroTPP.
Duplicate bone name found (‘HeroTPP’). Each bone must have a unique name.
Error Multiple roots found
Warning Could not find the bind pose. It will use time 0 as bind pose.
**

According to the outliner in Maya each bone does have a unique name and there is only one root. All I am doing is Exporting the HeroTPP from UE4 to FBX, Importing into Maya, Exporting from Maya and reimporting into UE4.

Bump!

I have the exact same problem and it is frustrating! Does anyone have a solution to this?

ok crystal ball time, it helps us if you tell us what you have done/doing also what program you are using and what content, pictures/video’s help lots

my guess is that you have exported the character and imported a modified version, the problem is that when you export a skel mesh from UE4 it adds an extra root bone (standard for fbx api) there’s a good chance that this “root” bone is named the same as the mesh, so you need to delete it before you export from your 3d program, the lowest bone name should be b_root , that is if you are using the Epic content

How do you delete this ? it seems I have to select the mesh in order to delete it , then it deletes the mesh also.or if I select the mesh and unparent, it disappears. if I select it and click “remove joints” it says it cannot remove a root bone.If I open the hypergraph and select and delete the bottom one, then the mesh disappears. It seems the top one is tied to everything so if I select it and delete in the hypergraph , everything disappears.

I think that’s the problem. You’re using an old FBX version. Here’s in the documentation: “The UE4 FBX import pipeline uses FBX 2016. Using a different version during export may result in incompatibilities.” Direct LINK.
Don’t know if this issue is true, but I had problems using a Max FBX 2014 version.

i’ll have to look at it, it seems when I export it goes to the 2013 version by default. I thought I tried a later one but it wouldn’t work.What I noticed is it wraps the skeleton on the top and bottom with the name of the mesh .

When I exported models from Max using the 2014 FBX version, it was a mess in the skeletal mesh editor. There were missed bones in my imported model and looked like it was hit by a truck. Not only the bones were affected, but also the skinning was destroyed. I’m using 2018 FBX version and had no problem.
As it can sound bizarre, still it might work: upload your character in Mixamo, create a quick rig to test, download as FBX and import to Unreal. See if it works.

what I have been doing so far is import into maya , don’t unbind skin at all , just go to edit mesh and then transform. make my skin changes. then go the hierarchy and rename the top skin/bone. with that selected(selects everything), then go and ungroup. which leaves just the mesh and root selected , then send selection to unreal.