Download

Import Rhino file using Dataprep Asset with Datasmith Import Options

Hi, Good Afternoon. Please help.

Is anyone know how to set Geometry option in Dataprep Recipe? This option is find in the Datasmith Import Options dialog if I import 3dm file directly.

Thank you. :slightly_smiling_face:

Hi, according to the documentation, after imported datasmith file,

you can still alter the settings on the content browser.

Change the data type to [CADimprot scene data] and check if this is what you want.

Hi zefreestijl,

Thank you very much for your reply. And the link to Retessellation page is useful. :+1:

It is good tips to know when I want to make minor changes to imported meshes.

As refer to your Datasmith Details screen dump, please refer to my screen dump:

I have changed my data type to “Datasmith CAD…”, there is no options under “Geometry & Tessellation Options”.

I hope to find out if there are any ways that I can specify during or before Dataprep import to set the option to either “Import as NURBS” or “Import Rhino Meshes”. With the Dataprep, I find that I got imported NURBS sometime and Rhino Meshes other time? I do not know why?

From my experiments when testing rhino file imports using Datasmith only. I find:

  1. the “Import as NURBS” option some objects created weird untrimed meshes. I checked that those objects have no bad surfaces and those meshes are enclosed in Rhino.
  2. the “Import Rhino Meshes” option gives better meshes but cannot be tessellated as point out in the UE documentation.

I am still learning and trying to find a workable solution to streamline the Rhino file to UE process.

Have a good day. :slightly_smiling_face:

@kchow321 Hi

Sorry I put the arrow at the wrong location,
my option settings are as the same as yours both in 5 and 4.26.

and you’re right, seems like only imported as nurbs object can be re-tessellated in UE,
yesterday I just pasted the context I read before but I haven’t tested it yet…-.-

about the untrimmed solid? or poly-surface file, can you gimme a screenshot?

I tried to import some model and all works well.

or have you tried to export model to sat or other format UE supports?

@zefreestijl , Hi

Here is the sample part screen dump from Rhino6 and I have saved the part “Save Small” to make sure no mesh was generated in Rhino. There is no bad objects with the part either.

Here is the Dataprep screen after “Import” . Noted the untrim large circle formed around the original part.

Here is the screen dump by import 3dm directly from Datasmith without Dataprep with “Import Rhino Meshes and UVs” option

I used Rhino6 and UE4.26 in these experiments.

Lastly, if I save the rhino file with meshes and create a new Dataprep Asset object. I can (sometimes) import the part as mesh. The untrim circle disappears. However, I cannot reliably make the Dataprep to import the generated mesh by Rhino6.

I don’t know maybe the error was caused by the fillet edges in Rhino?
fillet tool did has its problem sometimes…
maybe you can try sweeping a new one since it’s a closed model?

@kchow321
I am curious to know if you tried in 4.27 for test?
You should have a button to set the import options next to the input now:

@UE_FlavienP ,

Hi GoodMorning. :slightly_smiling_face:

Thank you for your information. I did not download the UE4.27 at present. I considered myself a new user learning UE. There are much to learn and explore even with the current version UE4.26. Secondly, if problem occurred, I knew it wasn’t an experimental feature. From your suggestion, it is a good improvement in UE4.27. I may install the Preview and try later.

By the way, in UE4.26, there are no other ways to control the Geometry option? From the import experiments with Dataprep that I tried. I found that occasionally it will use meshes generated by Rhino but not always. I just do not know what triggered the option to choose one or the other?