Download

Import obj?

Hello everybody!

I’ve just started playing with blueprints, and for what I want to try next I would like to create some props using a few free-to-use models. The problem is that I don’t have the slightest clue as to how one would load these (obj format) models to be able to use as static meshes in a level.

Now, I’m not an artist so please keep any explanations simple :slight_smile:

First of all download a 3d program (blender, 3ds max, maya) - now in the 3d program you have to open your obj file (mostyl you have to click onto import - obj -…) - then export/save it as a fbx file - now just import it into the UE4

Instead of using a 3d program, you could also use the Autodesk FBX Converter.

If you already have a 3d modeler, and it does not support obj directly, you can use a tool like Autodesk FBX Converter.

The fbx converter is free, btw…

Much appreciated! That should probably get me going.

We plan to add obj importing support to the engine! I think it will be in 4.2.

You guys/gals are full of surprises. :smiley: I’m sure obj support is going to make a lot of people happy as an Easter b-u-n-n-y.(for some reason the forum thinks b-u-n-n-y is a bad word. :slight_smile:

Wow, all of sudden! Good new :slight_smile:

I can understand forum.

Awesome news :smiley:

I tried this, but UE4 always freezes at 75% of the importing process. BTW: The file selection window offers also obj files for direct import, but the result is the same - freeze at 75 percent.

Has it something to do with the import settings?

New to Unreal; quick question that I have is regarding the import of OBJ. I noticed you said “probably in 4.2” but it seems that in 4.15 I was able to load an OBJ file that I exported from Inventor. When I import the OBJ though, I get all of the components that made up the object, but not the assembled object itself (in Inventor, this would be ‘parts’ and ‘assembies’). I then DL’d the FBX converter from AD, and made a 2013 FBX, and imported that (hoping to see the object) but got the same result.

In Unity, importing the OBJ works as expected; as a top-level “assembly” with the parts as individual children. Is there some setting I am getting wrong here?

My end goal is to use Unreal for product visulaization in Rift + touch; basically a simple “view room” that I place objects into and allow people to look at the objects using the touch controls to manipulate the parts.

UE4 doesn’t import hierarchies, when you import something you either have the option to make it a single mesh or separate each object to a separate mesh.

Thanks; yeah I figured out there was a below-the-fold option to either merge everything into one object (which looks as expected). The somewhat annoying thing there is that then (obviously) the thing can’t be disassembled anymore; I suppose the solution there is to import the parts and position them in UE, but MAN that is a super PITA. I mean, it might be feasible in an assembly with few parts and low tolerances, but for anything significantly technical it would take forever. I wonder what the logic is against importing a hierarchy? I mean, obviously it can be done, since Unity does.

It can’t be done in UE4 because it’s not designed that way, but there’s a kind of way to do stuff like it–there’s an Import Scene option where you can export all of it to FBX and it will separate out each object to a mesh and then create a Blueprint which will contain the positions of the objects along with maintaining instances (if you placed instances in your 3D program).

I have a 3d scan made with photogrammetry, meshroom. And when i try to import the obj made with meshlab, the mesh is emtpy. Autodesk convert, same empty mesh after import in UE, i only get the textures/materials right. The only way to get it right is to import it in blender, the obj file, then export FBX with blender. BUT there is a but, it loses from quality/details in UE… any tips where i should look ? thanks