Import not recognizing Skeletal Mesh Bones?

Hello all, I’m working on an object for my game that the player can use. I just rewrote most of my project and now I’m to the point where I need to handle objects the player can use again. I had a nifty setup before I restarted but now I am working on a lighter that the player can use. How my system worked before (back in 4.11) was I would model the object in Maya, create bones for it, and export it to Unreal then Unreal would see it as a skeletal mesh and I’d use the skeletal mesh in a blueprint for that item derived from a C++ class I made. This worked fine and actually produced pretty awesome results. I recently upgraded to 4.12 and I made this lighter in Maya 2016. Here is the process in the form of gif (sorry if it’s too big lol):

This is what I had before:
[video]Dropbox - File Deleted

As you can see, Unreal doesn’t recognize it as a skeletal mesh and it doesn’t see my bones either, but instead makes them from my meshes rather than using the joints I made. I’ve used the Export All option and I’ve tried Export Selection as well. I don’t know if I’m just missing something? This used to work well. Maybe I’m forgetting something since I haven’t done it in a while. Any help? Thank you! :slight_smile: