Download

Import new asset to the level takes ages, is it OK?

Hello everyone, I’m new to UE4.

I’ve downloaded and added this content to the project https://www.unrealengine.com/marketp…-collection-01

I’m trying to add HillTree_02 to the level, but it has been going on for about 20-30 minutes and still UE4 does not respond (although the CPU usage in the task manager is changing, it seems that it still does something). This is normal? Other assets took 5 to 30 seconds (stones, plants). I’m surprised how long it takes to import one tree (it seems to have about 50,000 polygons). Should I wait any longer?

My computer spec:

CPU: Intel i7 7700 3.60Hz

GPU: GeForce GTX 1070

RAM: 16GB

Windows 10

UE4 is installed on SSD, but the cache storage and projects folders on HDD.

I tried to kill the process and start over, but still the same.

That sample project has lot of high detail assets and takes a while to load

I have read most of the negative reviews for this pack and they all have problems importing two trees. Now I will pay more attention to the reviews before downloading. Thanks for your help, I am dealing with all this so far and it was awkward to spend 2 hours importing one tree. I thought the engine wasn’t very good, but the problem was in the content itself. Hope I won’t get caught up in these problems anymore, as I really like this engine.