Download

Import Into Level rotated 90 degrees

Hello,

I have a Maya scene that I am using File > “Import into Level” to get into UE4. It works great and looks correct but when I look at the static meshes, they are all rotated -90 degrees on the X axis, and the group on top has a 90 degree compensation rotation set on it. Normally I wouldn’t care but that means if I drag a static mesh onto the scene, that originated from that import, it’s by default not oriented correctly. I don’t have this issue when doing a regular import so I’m not sure what is wrong.

Any help would be greatly appreciated. Thank you very much!

When you export as FBX you go into the details at the opened export window and be sure to check option: Y-axis up!

I have tried tried both Y up and Z up and it imports the same way unfortunately.

I used Max and Blender lately… I do recall that Maya was different in another aspect… maybe search the youtube or internet would be better specifying “Maia Import into UE4”.

I have tried but no one is using the “Import into Level” option. If you drag it in and use the regular FBX importer then there’s no issue. I’ll keep looking though.

I’m having the same issue. It’s especially annoying if you want to port something over from unity. Sadly the import rotation option of the normal import isn’t available when importing into level, and the force X axis front option doesn’t work for me no matter if I export Y or Z up.