"Import High-Res mesh" feature for Nanite is crippled due to old FBX material ID bug.

As an update to this issue we have realized it is not the Nanite mesh causing issues but there seems to be a very old bug in the FBX import pipeline where UE messes up the material ID order in the static mesh sections.

A bunch of old threads describing the issue:

This issue is CRIPPLING the high-res mesh import functionality for use as an easy way to enable/disable Nanite on objects with more than 2 materials.