Import FBX from 3ds max screws up UVs

Hi, has anyone else had when importing from a 3ds max export. I have pretty much followed the settings here:

The UVs seem to repack themselves with the island layout being different from the one in max. The solution for now is to export as obj instead seems to keep the UV channel.

is happening to me too. I’ve done a few tests and Unreal seems to be repacking the UVs on import. Has been bugged?

Are you by any using 3dsMax 2015? If so, there is some kind of bug occuring with the way it exports…

When exporting from Max, in the export settings set the FBX version to FBX 2013, seems to fix the. Hope that helps! :slight_smile:

Yup, I’m using 3dsMax 2015 and exporting with FBX 2014. I switched it to FBX 2013, but the problem stays the same. It looks like its not repacking but the channel 1 (in 3dsmax), is being completely ignored in unreal. Channel 2 in 3dsmax is channel 1 in unreal (as expected) and channel 3 in 3dsmax is channel 0 in unreal.

It works properly if I throw a uv clear on the mesh and clear all the channels then use only channel 1 and 2 from Max. It only messes up with 3 channels, how do i get Unreal to respect more than 2 uv channels?

Anybody find a fix for ? It’s happening to me too.

Just add an STL check before exporting. It will fix the problem. Its a bug with Autodesk’s service pack.