Download

Import FBX failed from Blender file

Hello,

I’m having trouble getting my blender FBX file to import into Unreal Engine. I’ve watched several tutorials and can’t find a solution. OBJ does not seem to work either. I’ve successfully imported files from 3ds Max and C4D before but trying Blender is giving me issues for some reason. The errors in UE4 are “Could not find any node” and “Import failed”. Here are my export/import settings:

BlenderExport.PNG 9be4858bc65a5b32faa673b80ae12a8efcbeaab7.png

ok we need a little more info in what your doing
static mesh or skeletal mesh, which version of blender and ue
would advise using the fbx 7.4 exporter

a bit more info on the mesh might help as well

It is a static mesh, just a single poly plane. I’m using Blender 2.73 and UE 4.8. I tried the 7.4 exporter as well with the same result.

ok try this , sub-divide the plane a few times, make the uvw’s , add a textures then export again,

i’d think about upgrading to blender 2.75a

Thanks Geodav. I upgraded to blender 2.75a and subdivided the plane and still did not have any success. I tried creating a simple cube in a new scene file and bringing that into UE4 which worked. I tried simply creating a new cube in the scene with my other meshes which did not work. It appears the problem is with my scene. I would really like to avoid losing my work if possible, I only recently started using blender so I’m not sure how to fix the scene (I usually stick to C4D and 3ds Max). Any ideas?

Blend file with your scene would help people understand your problem

+1 for that, then it would be easier for us to solve the problem :slight_smile:
Otherwise post a pic of your mesh + export the entire scene (so not just "selected objects)

It’s going to sound silly, but I see that you have “Selected Only” checked. Are you sure that the plane is selected? If there is only one plane in the blend file, FBX file, then uncheck this and see if you still get the error.