Download

Import collision

I know there are many discussions on this already but I can’t seem to find a solution to this. I have made a basic empty building with wide openings where doors go so you can just walk in. I have even kept side walls off for testing but I can’t get the collision to work properly. When I import to UE4, it creates the collision around the exterior of the building and you can not enter it. I have tried creating the UCX_NAME copy in Blender but I still get the same issue. What can I do to allow for the openings and have a “hollow” interior? So far I have just tried one big open room but this will need to become complex layouts.

-disable “one convex hull per…” + auto generate collision in your import settings
-make sure that you have used the exact name of your mesh + UCX_
-take a look at this video: https://www.youtube.com/watch?v=TTsAYpqHU-c :slight_smile:
-you could also use the “use complex as simple” to get the perfect collision

Thank you fighter. I changed the one convex setting and now I am not getting any collision… Thoughts?

Have you also changed the “auot generate collision”? -> because then your collision mesh is not working (then you will have to check the names again)
Could you post a screenshot of your mesh + collision mesh or when it’s possible it would be good if you could upload the mesh somewhere so that I can find a quick solution :slight_smile:
But normally when you do it like in the video, it should work perfectly

SS1.jpg
d47f624348bfc9131c12ddea7dccaa22cc9dc8c4.jpeg

  1. use basic shapes for your collision! -> dont just copy and paste the original mesh
  2. disable auto generate collision
  3. it seems like you havent exported your mesh correctly -> how do you export your mesh?

I used a cube in one area of the mesh and that worked. Why does a copy of the mesh not work? I created the original mesh in Sketchup and exported as a dae file. I then import to blender and export as fbx. I can export as an FBX from sketchup but I still get the same issues. I would like to avoid using a ton of basic shapes since the final building will have many walls and doorways. Is there a way around that?

The easiest workaround for that is to use the “use complex as simple” collision setting in your mesh -> 3d way that I show in the upper video :slight_smile:
But it’s better for the performance when you use basics shapes

Worked like a charm, thank you fighter!!! I wouldn’t use it this way in a larger scene/level but this project is going to be a low object small scene and hopefully won’t suffer from it. It if does, I’ll make a bunch of simple colliders for each wall etc.

What if there is no “use complex as simple” option? I have absolutely no option to set the complexity of the collision upon importing an FBX or OBJ. So if this advice is wildly outdated then I really need a different answer.

@waynechriss You set this in static mesh editor. Details > Collision > Collision Complexity.
@fighter5347 Is there a way to import ONLY collision ?
Exporting SM fbx from unreal and importing it again (with added custom collision in Blender) ruins shading for me, shading on some parts of mesh is not smooth but flat (making visible triangulated faces) and I can’t find any way to fix this.
I import pretty much same fbx, without ANY changes to it (just exported from blender with UCX) and things are broken, its crazy.

Just fix the shading by exporting the proper shading mode edge/face.

Also you can always build the collision in engine manually. go to the collision drop down menu, click one of the options. see how the collision is built for you.
You can increase the number of hulls as well in the specific collision panel.