Download

import animation issue

I’m having a problem with the export/import process between Maya and the Unreal Engine (as you can read in the title).
I have an animation (it’s an idle animation for a third person shooter), which uses the standard Unreal Engine Mannequin,
that was bought from the marketplace and exported from Unreal Engine to Maya using an .FBX file. Then I constrained the wrists and the legs,
so they won’t move, because they were causing problems when blended with the AimOffset poses (ik moved seperately from the wrists/ankles).
I baked down the constraint and exported the animation to Unreal. After opening it in the Editor the animation somehow “wobbled” out of place,
none of the baked constraints seem to have been done correctly. I imported the exported animation into Maya again (later even blender),
to see whether something with the export went wrong.

But everything looks fine in Maya and Blender. I looked for help on the internet and the ue4 discord. Stefan (Adeptus) reached out to me, and had a look
at the maya source file. Turns out the constraints I baked were done wrong and they baked world offset into the wrist and leg bones translate.
It seems there is something foul with unreal mannequin skeleton and translate values from anim. He did a simple test by just animating the wrist bone and exporting that.
But the anim was not working in ue4, just a static bind pose. He then tried it with his own custom skeleton and it worked fine.
(A little tweak to import options had to be done to use -use the default sample rate) But even with those settings the same test on the ue4 mannequin did not work at all.

In the FBX exporter make sure that “Bake Animations” is checked?

I dont think thats the issue as on his anim file the anim was already baked per frame. But ill make a test later.