Download

Import a .uasset file

I created a new blueprint last week and i can’t import it in my project, it’s located project/content but it’s not in the engine, i’ve tried to drag and drop it but it’s saying ''Unknow extention ‘‘uasset’’ ‘’ ?!? Please help me i don’t wanna start over !

So I had same issue last week and this is how I found to work around the issue:

This can be used for materials or blueprints. Open blueprint you want to move, select everything and copy, paste it into Notepad. Then copy your notepad contents to the blueprint opened in the new project. Every now and then you do have to make a connection or two but should save you a lot of work.

Hope that helps.

if the blueprint is in another project then you need to use the migration tool

open the first project then select the blueprint right click on it and select “migrate” follow the instructions to the path of the new project

The probleme is that my blueprint is in any of my projects, I don’t know what happened, so I can’t open it ! I see my .uasset file in the content of my project when a go to mydocument/Unreal/Project3/Content/Blueprints. But it’s not in my content browser when a open my UnrealEngine project

Have you tried making a placeholder asset in the editor, close the editor, replace placeholder uasset file and start editor again?

Hi nomousse,

The best way to go is to ‘migrate’ from the old project to the new project. Open the old project and select the asset or assets you want to move in the content browser and choose Migrate in the context menu. It will automatically figure out the whole ‘web’ of asset references that need to be moved, and then you pick the destination folder (the content folder in the target project).

If you no longer have the old project, you can try placing the .uasset on disk in the Content folder of your new project while the editor is closed, then open the editor and try to click on it there. There’s no guarantee this will work, if there are referenced assets missing, etc…

Cheers,
Michael Noland

It’s not working :frowning:

It’s not working :frowning:

same issue here, but under slightly different circumstances. But laptop crashed and it seems that the blueprint was corrupted in the process. When I tried creating a new blueprint with the same name, udk said “cannot change file that is not fully loaded”. So, there may be the need of repair information or temporary changeable files, especially as long as that stuff crashes so often…

Hi,

If UDK said that, its maybe time to switch to UE4 :rolleyes: Its only 19 bucks a month :wink:

But I keep regular copies of my entire project folder on an external disk. That way I can revert things very easy…
In the old days we called it “backup”…

Cheers,
Klaus

I cant import or load uasset. Through vrowser I can see they are there, but when try to import it just not filtering uasset extension. How do I import?