Download

Import a skeletal mesh from MAZYA to UE4 : Low skeletal mesh resolution

Hi everyone,

I try to import from MAYA an **HIGH SKELETAL MESH RESOLUTION + ANIMATION inside ue4.14 ** but without sucess:

Methode 1:

a. First i import a skeletal mesh from DAZ studio inside MAYA 2016. I tried within FBX or DAE (That works better)
b. Inside MAYA, the mesh and the animtion are imported sucessfully.
c. I apply the SMOOTH (mesh/smooth) to a mesh in order to obtain a best resolution.
d. Next i export to UE4 (within FBX) but “without surprise”, the mesh is low resolution inside UE4 (UE said that no smoothing group was found)

** Methode 2:**

a. I create a LOD group inside MAYA (all is ok)
b. I smooth one copy of the LOD group (in order to have a best resolution)
c. I export the LOD group to UE4 (FBX)
d. UE4 accept to import the mesh but not the skeletal. (if i choose the skeletal it brings a CRASH inside UE4)
e. The mesh is perfectly high resolution. But i can’t import ANIMATION…

Methode 3 :

a. Inside MAYA, i tried to generate a LOD GROUP
b. But i did not success to import the smoothing group (only one time, bit i don’t know how!)

**I tried: **
GAME EXPORTER
FBX: 2012-2013-2014-2017
I tried to import with or without normal-tangent -binormal , lightmap option (import FBX UE4 option) etc.
To convert the mesh

Nothing works really:
**I never have at the same time: **
HIGH SKELETAL MESH RESOLUTION + ANIMATION

I searched for hours and hours wihtin google, forum… I discovered that others met the same problem.
They sometime solved it (or believed to solve) I hope the solution is basic - imagining that it exoists an issue…!

In advance i sincerly thanks you for your help or advices.
David.

Smoothing groups are different from meshsmooth–they define which surfaces are treated as one surface so that rounded parts look rounded rather than faceted. Meshsmooth will subdivide the mesh and increase the number of segments to make the rounded parts more rounded so that you can’t see the segments on a silhouette.
Your issue though is that the smoothing mode in Maya is not applied, you’re just showing it visually within Maya and it needs to be collapsed—I don’t use Maya so I’m not sure the workflow to apply smoothing so someone else would have to help with that.
However, I can tell you that you can’t subdivide an animated mesh and maintain the animation when you export to UE4, the mesh has to be skinned to the animation rig after you subdivide the mesh. A different workflow would be to export the mesh to UE4 and then use real-time tesselation to subdivide the result like you want: 1.8 - Tessellation | Unreal Engine Documentation

Hi Darthviper, Thanks a lot for these advices.

That’s because when you import the fbx, in order to take the full mesh resolution, you have to check Import Mesh LODs