Image Widgets Always Transparent

I’m using UE 4.7.6. In the UMG Editor, I’m adding an Image Widget, and making sure that it’s Alpha is 1.0 (fully opaque). However, when I run in editor, the image is always 50% opaque. I’ve checked all the settings I can find on the texture, the panel, the class, the parent class, and the image widget itself – but none of them seem to set or change the transparency.

So, why is my widget at 50% opacity when I specifically set it to 100% opacity?




I have the same issue on 4.9.2. Did you manage to find a solution for this?

Ha ha, same issue for me except that my image is always opaque and i want it to be transparent u;u

Check if the widget’s “bIsEnabled” flag is set to true. Excerpt from the thread on the UDN:

Hi there, not sure if this was fixed already in the later builds…

If I set a widget’s ‘IsEnabled’ (Behavior) flag to OFF, this widget and all its children render in game with a reduced transparency (I’d say ~50%), their colors being washed out.

Answer by Epic games:
Nope, that’s something that’s inherent in Slate’s handling of the disabled state of widgets. There needs to be a better/more customizable handling of it though. If you’d like to simply disable input but not get the effect, changing to visibility to HitTestInvisible will more or less achieve the same results with no visual state change.

1 Like