I'm not able to view the engine source code on GitHub

I followed all the steps on the following page:

and I’m still not able to view the source code on GitHub,


I get a 404 error. I emailed back and forth with Epic employees and they sent me to the Unreal Engine support page. Is it possible to get help on here from an actual Epic employee??? Please help.

Hi Tecneecs

Please follow the steps listed on this guide for setting up the access - Unreal Engine 4 on GitHub - Unreal Engine

I hope this helps


Thanks for your help, I had completed all those steps previously, or at least I thought I did. Even though I was showing as part of the Epic organization on Github, I was not seeing the private repositories.

So I decided to unlink my accounts and start again from scratch. I had to unlink my Github account from Epic. Then, I went to Github and made sure I removed the Epic organization and revoked the OAuth authorization to Epic. I pretty much made sure any mention of Epic was gone from my Github settings.

This time, when I linked my Github account on Epic and received the join link in my email, I clicked it and I was able to join the Epic organization on Github with no issues.

Now I can see the private repositories! Thanks again for your help and for taking the time to answer.


Stephen, thanks for your help. I figured it out. I had to start from scratch. I posted my solution below.

Glad that worked. We recently experienced an issue over a few days where new users were unable to join the Github org. Your post was made after it was resolved, but perhaps you had originally tried earlier?

After we fixed the issue, the people who had previously been blocked needed to go through the exact same steps you listed in order in order to reset everything and try again.