Im done with trying to make google play services work with blueprint ! , please help?

Hi All
Im just trying to add leaderboard to my game using blueprints , its just not working and i don’t know why ! … I used “Show plateform specific leaderboard screen” , its just not showing anything in my game like im not using anything …
I configured my leaderboard in my google play developer console , i linked my app to it , I used two sha1 keys one of the debug keys , and the other of the distribution keys which i made previously i have tried to package with shipping and development mode but its not working in both cases , I published to alpha test in my google developer console , and downloaded my game , and still not working ! , I really don’t know what to do anymore , please help me :slight_smile:
PS :- I used this link as tutorial Google Play Setup - Mobile - Epic Developer Community Forums
And I have installed google play services SDK
I appreciate your help…

Any help please ???

Any update please ???

I am having simular problems. Took me forever to get in-app purchases working but still having issues getting android game center to work. Had better luck getting it to work with ios.

Well guys , I resolved the problem … the problem was in my blueprints , I didn’t add (Show external login UI) Blueprint.
I didn’t notice this problem because of this link in Unreal Docs !!

You mentioned just the following Blueprints (Read Leaderboard Integer), (Write Leaderboard Integer), and (Show Specifice Leaderboard screen) , but you didn’t mention the (Show external login UI) Blueprint.
Wish you mention it so none would be in same problem!!.
Thank you.

still having issues getting this to work. Can you show how you connected it up?

Connect it this way , and make sure of the following :-

  1. It won’t work just with mobile , it won’t work with the editor or on pc
  2. Make sure that you have filled google play services and you enabled it in the project settings > Android
  3. Make sure you have added a google play services in your google developer console and signed the correct keys for it ( You have two keys , Debug keys , and shipping keys) , you can check this link to understand more
    [link text][2]

Is still ocurring?
As EngAliHussein answered:

For me what I have done and helped me is:

1° Credentials Check:

  • On Google Play Console, check if the “Google Play App Signing” is ON

  • Navigate to your project directory\Build\Android and check if the certificate is the same in Google Play Consle

  • Go to Google Cloud Platform? and check if the “Client ID OAuth 2.0” are the same of the Google Play Console App signing

2° Google Play Check