IK in control-rig deforms mesh unexpectedly. 4-27

I am trying to get a simple leg IK working. The model and rig is made in blender and it is from a game-rig tutorial. The leg IK works perfectly in Animation Blueprint, but it messes up the mesh when i recreate it in Control-rig.

This works perfectly and as expected.

Here you can see what i mean with messed up mesh.

The scale on all the bones are set to 1 which should be correct. Blender scales aswell. i’m using the ‘Send to unreal’ addon in blender. I’ve also tried manually exporting an FBX but did not solve this issue. How come this works in ABP but not in control-rig?

Ok i figured it out by changing setting the primary axis to x0, y-1, z0 and the secondary axis completely empty.

(Foot is now upside down)

Not sure why i had to change these settings when ABP works in one go. Couldn’t find much information on these two axis, most tutorials did not even touch these values, even the Unreal channel skipped it.


Hey, I’ve seen this BlueGuy somewhere lol

I am just learning Control Rig and am trying to figure out the Primary/Secondary axes. It’s confusing for sure but I think I am starting to get the hang of it.

The Primary axis is the one that runs along the length of the bone. In Blender, that’s always the Y-axis . So it makes sense that you had to set the Primary Y to -1. I guess the negative value comes from some fundamental difference in the coordinate systems of Blender VS UE.

In UE the Primary axis is X by convention although you are free to change it (unlike Blender).
I guess most tutorials work with UE-compliant rigs and that’s why they don’t need to tweak these settings.

The secondary axis, I haven’t fully figured out but I think one simple way of thinking about it is:
“the axis on which the elbow or knee would rotate”. In Blender that would be either X or Z.

So … I need to test this more but I think if you are careful with your Bone Roll in Blender and
-make your arms, knees, fingers, etc. bend on the X axis…
-and then in the FBX export settings set Primary: X, Secondary: Y (or possibly -X and - Y, needs to be tested)…
then your rig will behave correctly in UE without tweaking the IK axes.
Or you can work with Blender’s defaults and remember which IK axes you’re supposed to change inside UE.

1 Like