Download

IK Foot Placement

I created IK Foot Placement for my character but he is walking on the water instead of going through, I think the problem is here, check out the node I circled (when I change Z number from 151 to 0, he is walking through water but there is no IK anymore ). When I remove IK, he is walking through the water as well.

Hey,

have you tried to set the collison on the water to ignore - visibility ?- then the IK should ignore the calcu. to the water and you shouldnt walk on water.

Hi thank you for your answer, yes I did try that, but its the same :confused:

Try setting the Draw Debug Type property on your line trace. If the water is set to ignore the Visibility channel, as shikaN.e said, then the trace should go right through. If not, then please send a screenshot of your water collision settings.