Download

IK constraints stretch vertices to steady points on the ground (Static Mesh, 3rd person ex.skeleton)

Hello,
I’m working with replacing the skeletal mesh from the 3rd person example with my own, while building upon the same skeleton so I can keep the animations without retargetting.

The problem, as seen, is that the IK bones/handles (not sure what they are exactly) are stretching a vertex from each limb, onto a steady place on the ground. I checked in Persona that it is the ik_hand_l, ik_hand_gun, and I believe the two IKs for the feet, but I couldn’t make out much more of the exact name because of overlapping bone names.

6dcbfef5580e690ea2b7980026703a660c5dadd1.jpeg

Development of the mesh:
I used Autodesk 3DS Max 2016 student edition (shouldn’t be any different from the normal one), I exported the character from UE4, imported it, fixed the hierarchy so re-importing to UE4 would result in identical results, and then edited the editable mesh, thus leaving modifiers etc intact. I deleted all triangles except one, and started building from there.

Other problems encountered:
I also had flickering, but deleting the physics asset did fix that, as was suggested in other posts.

I hope I gave all necessary info, many thanks in advance!

this looks like a rigging issue, it would seem that you have control bones that for whatever reason have influence over those vertices when they shouldn’t.

Sounds reasonable enough… Given that I only edited the existing mesh and didn’t mess with the bones or skin modifier, could you suggest any specific procedure, preferably shown in a walk-through?

Sorry, I don’t use 3dsMax, so I don’t know how to translate the process from blender.

But basically, you find the problem vertices in 3dsmax, and assign them to the correct bone with an influence value of 1 (maximum influence).

If you could upload the FBX, it would be easier to diagnose.

Ok, I’ll try it out in the few following days, if I don’t figure it out I’ll upload for a second opinion. Happy holidays and a happy new year :slight_smile:

Hello again, I had no luck (though I also had little time to devote so my check may not be as thorough as I would like it to be) with weights, at this point, if anyone is in the mood to take a look, I would be in debt to whoever figures out what’s messing things up.

Another thought I had: earlier I had messed up the skin modifier (not on this model), and the mesh appeared face-down on the ground, in the T-pose, and if I remember correctly it didn’t animate, or if it did, it was these IK handlers in particular. There may be a chance that the IKs are in that same location for whatever reason, but I have no idea why they would do that, or why only they would do that, and not the entire skeleton.

You can get the FBX here (don’t worry, the link should remain active for a good 2-3 years or so)

You have vertices weighted to the IK bones. (as said before)

If you don’t know how to fix that you should probably post in a 3dsmax forum instead.

Or, just use blender. :cool:

In blender: open vertex groups in object data tab, go to the ik bones, select one and click Select to select all vertices weighted to that bone, then click Remove to remove all weights. When you’re done, move the whole rig in pose mode to find out which vertices aren’t weighted. Then go into edit mode, enable Display modifier in edit bone and Adjust edit cage to modifier result on the armature modifier, then select the vertices that aren’t weighted and go back to the vertex groups list and find a reasonable bone and Assign.

Then do the same for the root bone, some vertices were weighted to root.

well, I’m not sure if this is a comparable issue, but I had some similar problem a while ago (Weird Set Master Pose behaviour - UE4 AnswerHub).
turned out my skeleton had some errors (rigging error). could you post a screenshot of your skeleton (the tree hierarchy with names) of the UE4 skeleton asset?
if there are any bone names “greyed out” (light grey instead of dark grey) this means there could be your possible cause.

@cyaoeu, that was in part true, but even after I removed all weights or set them to zero (as I haven’t studied Max independently I couldn’t always persuade it to remove the binding entirely) and verified through the Weight Table I had roughly the same effect.

The eventual cause was that those vertices were not bound to any other bone, so they retained their original position, only with the original being face-down (for some unknown reason, but it’s the same with the default character, after comparing the IK positions during animation), so I had to check that all the bones around that area influenced all the vertices, and assigned any stray vertices to a bone. After hunting down the last one I got proper animation!

@btengelh, the skeleton asset appeared quite normal, all bones had the same color (their name, that is). If it did turn out to be that though, would I also see deformation on the default character and anything else sharing the same skeleton? I would suppose so, as the asset is essentially shared between them, rather than the skeleton istelf…

The solution:
Make sure IKs don’t have a weight on the bones, which they shouldn’t by default, but also make sure all vertices are influenced by at least one bone!

Yeah, that’s pretty much what I was trying to say, make sure that those vertices were assigned to the correct bone :slight_smile:

I’m glad you fixed it :slight_smile: