Download

IK Bones and other Bones are disappearing, when export it from UE4 to Blender. (VRoid and ALS V4)

Hey, I don’t usually ask for solutions and try to find them myself, but I’m stuck for several days. My problem is when I export (via fbx export) a mesh that has the same skeleton as ALS V4. I import as fbx & edit it in the blender and delete everything on my char mesh except the pants, because I want to give my guy clothes. When I’m done, I export it again as fbx and import it from UE4. But the problem is, when I select the skeleton of my char it says “Failed to merge Bones” :(. After I click on “No all” and try to fit the pants to my character and his animations, the pants don’t fit and are bent. I think, that when I export it to Blender my IK Bones are gone or are renamed. Please, if you are reading this and have only one suggestion Post it anyway, any help is welcome here. :slight_smile: Here is a Google Drive link, which will lead you to pictures to understand it better. https://drive.google.com/drive/folde…aN?usp=sharing
Sorry if you don’t understand the text so well, my English isn’t so good :smiley:

Sounds like a bad approach.

Take the good skeleton/character and export it.

Delete the mesh from it, leave the bones.

Save as.

Open the pants, delete the skeleton after unparenting the mesh.
copy the mesh.

Open the file you saved before that only has armature.

Paste the pants.

Double check that your vertex groups are named correctly- the names have to match the skeleton.

Edit the pants armor modifier by selecting the correct armor (only one you can choose now).

Parent the pants to the armature - shift drop onto it. It should not ask about weight groups.

Save new file.

Export out as FBX wit proper smoothing group and import into unreal.

You should have working pants.

Hey, first of all, thanks for the answer. :slight_smile: I’ve done just about everything you’ve written, but what do you mean by the armor modifier? Do you mean the Shrinkwrap modifier?

I tried your steps, but it didn’t work. After “analyzing” I found out that the IK Bones and the other bones were even in the right place, they just had different names. So I renamed each bone exactly after the mesh, that was in UE4. After that it worked like a glove.:slight_smile: I could export them from Blender and import them into UE4 without “Failed to merge Bones”. :DIn the end it was such a simple solution, and I feel dumb right now that I didn’t see it before. But I’m glad I found it late instead of never.