Ignoring specific mesh on physics simulation?

Hey, i need to stop one body that is simulating physics ( let’s call it Michael) from colliding with another body (which doesn’t simulate physics, let’s call it Peter).

How can i set it up without creating a custom collision channel?

Try the “ignore Actor when Moving”, but if your want it component wise, there’s also “ignore Component when moving”

this only works for meshes that don’t simulate physics.
in my case one of them does simulate.

bumpy bump

To disable collision between indicated physical body pairs you need to create your own ContactModifyCallbackFactory derived from IContactModifyCallbackFactory and ContactModifyCallback derived from FContactModifyCallback.

Or just use my plugin

hmm interesting. it’s a very old thread so it’s irrelevant for me currently, but i might try that in future and report back. thanks for the reply