Download

IgnoreActorWhenMoving behaving different from PhysX

I’m fairly new to unreal but to not game dev (16 years exp). I have used PhysX directly in my own engine code (and other engines with PhysX), so I know there is a physics ignore actors functionality. The UE4 IgnoreActorWhenMoving does not seem to work.

For my test, I’m spawning an Actor (shield) with Instigator, and setting IgnoreActorWhenMoving on the instigator EventBeingPlay. That does not work at all but I see stepping through the blueprint, the instigator is set correctly.

6f51d0c3b9fccc2efc694bf3c0c4f2990582c23b.jpeg

ffcdc7ae2e5c28d8cbbf5fc3c7159fd5447a8439.jpeg

I seen other proposed “hacks” but they don’t work in my situation

  1. use collision layers to ignore collision.
    This only works for single player games. It does not work for multiplayer games or with AI, and I really just want to ignore my spawned actor with the instigator only.

  2. Setting delay to create the collision.
    Does not work on a shield I attach to follow my character. For shields like this

lZeSPmA.png

  1. Disable physics.
    Err, what if I want my projectile to have physics behavior like a ballistic? Not a bouncing effect in projectcomponent.

I’m using 4.15.2, I seen dated thread back to 2014 that have same issues but no proper resolution. Am I missing an API somewhere Is there really no proper for ignore actor (in C++ is fine) or this seems to be a terrible bug/limitation?

I think that both actor that are colliding should ignore each others, and not just the spawned one, but I could be wrong