Download

Ignore base/parent Rotation from child components

In the view editor for an Actor, where you can add components, I can’t seem to set Absolute Rotation or Ignore Base Rotation
I believe i can do it during the game when Spawn + Attach Actor - but I’d like to be able to do it from here.

Am i missing something? Is there a reason why you can’t do this?

For example, in the third person template, I’ve told my camera to ignore rotation so it is fixed on the Pawn pointing down (like original Metal Gear Solid on psx), but now when my pawn turns, the boom’s location moves around with him. I’d like to be able to offset the boom/camera location so the player is just to the side of the camera.

Cheers for any info/help

Have you tried disabling the “Inherit Yaw” setting in the SpringArm properties?

yeah, i currently have all the properties disabled (Use Pawn Control Rot, Inherit Pitch, Yaw, Roll) - they are all False

This is happening with other components I attach to my pawn (within the blueprint), they can’t see, to “ignore parent rotation” - is this maybe a bug ?

Go to your spring arm component and under Transform set the Rotation to World(absolute), this should keep your camera boom from rotating at all.