"Ignore Actor when Moving" function isn't working

Hello Guys,

I have a physics actor that the character is shooting and i want the actor to ignore collision with the owner so the character can go through the actor. I found out that there is a BP function called “Ignore Actor when Moving” but it isn’t working for me. I dont know what im doing wrong.

Thank you in advance for helping me!

Hi. Make sure you also do this ignore when moving stuff for your projectile to your player pawn.

You mean like this? Then it isn’t working still >.>

no, you are doing same thing twice now :slight_smile:
in short your pawn should ignore projectile, and projectile should ignore pawn. that way they would ignore each other and doesn’t collide at all.

1 Like

Isn’t working still >.> On the left is the CharacterBP and on the Right the Actor BP

on the left side just put that spawned actor pin as target to second “ignore when moving” node and self as actor.

Like this? It isn’t working for me still >.> Can you help me maybe over Teamviewer or Skype?

are you sure it even spawn? may be try that “spawn even if colliding” first?

Im sure. Watch the Video pls. It shows the code short and the spawning actor that i hit. [Video][1]


now the only thing left is character mesh, what happens if you also add ignoring mesh as target?

Still it isn’t working >.> what could be there wrong

it looks like a bug. which UE version you are using? can you test this behaviour in other versions? i have almost identical setup with default character and it works for me with 4.9.2

Ok i will test it out in a newer version. Used Unreal Engine 4.8.3 for my Project. Need to update first version 4.9

Hmm, i updated to 4.9.2 and made a new Project to test it but it dont work… could you help me maybe over skype oder something like this?

i’m sorry i don’t have mic and going offline soon. but here are super simple example. just 3rd person template, added quick projectile blueprint derived from actor, replaced root with sphere collision and add sphere mesh for visual. set shoot logic on left mouse button. works as expected.

now i noticed one thing, when your projectile root is not collider you need manually get its root comonent and cast to primitive component to be able connect it as target for “ignore when move actor”, but it works anyways, just a few extra nodes.

Ok i see the Problem. My Actor is a Physics Actor like i said at the beginning and you used a actor that isn’t using Physics… I tried it out myself and it worked but i need the physics

In fact you can just use custom collision preset and ignore/overlap pawn from there depending on what you are trying to achieve.

its a multiplayer game so it would be ignore every pawn but i want it to ignore only the instigator

It would be a bit easier if you just describe what you are trying to do…

If it supposed just to block movement then you can just make actor overlap pawn and set your custom overlap event which pushes out other pawns but not instigator, hacky but works.

Second option, if you really absolutely need to simulate physics and there is let say 8 players or less, set up collision channels[1] for each player with desired collision setups, for example channels like “player_1”, “player_2”, etc, which would ignore self collision.

There is also third option, using C++ there is PhysX function for scene something like “pairflags” which you can use to ignore actor pair collission.

Also, besides ignore when moving function in BP there is also MoveIgnoreActorAdd[2] function, though i never used it.

[1]Add a Custom Object Type to Your Project | Unreal Engine Documentation
[2]APawn::MoveIgnoreActorAdd | Unreal Engine Documentation

a bit off-topic, but…
Why ever simulate physics? Maybe this option misleading you? I mean making obstacle definitely would block player even without this. triggers and other volumes doesn’t simulate too and still blocks/overlaps stuff. Also how would you replicate physics body? Let say for example my average ping for central Europe is about 150-200 ms and about 250-400 ms to US (i have good 100 Mbit channel), believe me everything above 150 is barely playable, and that is without any physics, now drop the physics on top of this and it will be not playable at all