Ignore a type collision

What i need to do is spawn different controllable actor and let them ignore ignore collision from each other.
So i setted collision to worldstatic (otherwise they will fall under the ground) and let everything else to ignore, also i set the type as pawn but they still collide…
Look to my settings here:


What’s i am doing wrong?