If Widget Component User Interface`s Geometry Mode is set to Cylinder, the button of binded UserWidget can`t be clicked.

Just as what I said on the screenshot.How to solve this problem.


I have confirmed that。You can check the screenshot that it is enabled。Hardware input will be disabled if you set cylinder mode.

and I’m sure that my way is rig

ht cause if I change the Geomotry

Could you confirm that:

  • hardware input on the widget component is enabled
  • the widget hierarchy has enough Visible / Self Hit Invisible elements for the input the reach the button

Right, this is a cylinder. So how does your script for the widget interaction component look like? You need to send a specific input key/button through to the component.

So how does your script for the widget
interaction component looks like? You
need to send the input through the

Normally, this is done in the Pawn or, better, in the Player Controller:


Also, don’t forget to set the source of interaction - depending on what is needed; for clicking the mouse:

ok,i`m trying to use WidgetInteraction like what you said.

The script, mate. See my answer below. Seems to work just fine in 4.27 (and it 100% worked in 4.25):

Image from Gyazo

If you still cannot get it to work, double check the widget hierarchy I mentioned. Your arrows do not answer that at all. Perhaps something got accidently blocked - every native widget has its own granular setting for this:

And, just in case, the tut with a timestamp:

alt text

Yes, sure. Why not.

Could you show the hierarchy of the widget with the buttons? And the details panel of the button that is misbehaving? Are there any offsets/padding? Did you translate position?

This button’s details panel:


It seems you’re using multiple canvas, a bit strange - does it mean that you’ve laid out everything manually? Hard to tell more without seeing the details.

It might be hierarchy :expressionless: We’ve got nested canvases inside other canvases. Not the best practice in general but who knows. Could you try something quickly and see how it behaves:

Replace your widget with this, just for now, just to test it and see if the click area matches the one the interaction component hits. All other settings at defaults.

And I will test it in a clean project 4.27. maybe my project setting has problem with mouse setting